aboutsummaryrefslogtreecommitdiffstats
path: root/perl-file-tail [moved to community]
diff options
context:
space:
mode:
Diffstat (limited to '')
-rwxr-xr-xperl-file-tail [moved to community]/-watch-21
-rw-r--r--perl-file-tail [moved to community]/.gitignore1
-rw-r--r--perl-file-tail [moved to community]/PKGBUILD27
3 files changed, 0 insertions, 49 deletions
diff --git a/perl-file-tail [moved to community]/-watch- b/perl-file-tail [moved to community]/-watch-
deleted file mode 100755
index 2f81b76..0000000
--- a/perl-file-tail [moved to community]/-watch-
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/bin/sh
-
-[ -f file-tail ] && rm file-tail
-
-wget 'http://search.cpan.org/~mgrabnar/File-Tail-0.99.3/Tail.pm' -O file-tail >/dev/null 2>/dev/null
-
-if [ $? = 0 ]; then
- [ -f unfetchable ] && rm unfetchable
- grep 'Module Version:' < file-tail | md5sum > new-sum
- touch sum
- if [ "$(cat sum)" = "$(cat new-sum)" ]; then
- rm new-sum
- else
- mv new-sum sum
- echo 'perl-file-tail'
- fi
-elif [ ! -f unfetchable ]; then
- touch unfetchable
- echo 'perl-file-tail (unfetchable)'
-fi
-
diff --git a/perl-file-tail [moved to community]/.gitignore b/perl-file-tail [moved to community]/.gitignore
deleted file mode 100644
index 818ee96..0000000
--- a/perl-file-tail [moved to community]/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-file-tail
diff --git a/perl-file-tail [moved to community]/PKGBUILD b/perl-file-tail [moved to community]/PKGBUILD
deleted file mode 100644
index f048c58..0000000
--- a/perl-file-tail [moved to community]/PKGBUILD
+++ /dev/null
@@ -1,27 +0,0 @@
-# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
-# Previous maintainer: Kevin Piche <kevin@archlinux.org>
-
-pkgname=perl-file-tail
-_realname=File-Tail
-pkgver=0.99.3
-pkgrel=5
-pkgdesc="Perl/CPAN File::Tail module for reading from continously updated files"
-arch=('any')
-license=('PerlArtistic')
-url="http://search.cpan.org/dist/${_realname}/"
-depends=('perl>=5.10.0')
-options=(!emptydirs)
-source=(http://search.cpan.org/CPAN/authors/id/M/MG/MGRABNAR/${_realname}-$pkgver.tar.gz)
-md5sums=('ef0fb7bcb4181ba593f4a09940f61d1c')
-
-build() {
- cd $srcdir/${_realname}-$pkgver
- # install module in vendor directories.
- perl Makefile.PL INSTALLDIRS=vendor
- make
-}
-
-package() {
- cd $srcdir/${_realname}-$pkgver
- make install DESTDIR=${pkgdir}
-}